postgres ??? qual versao??

Discussão sobre dados técnicos do Compiere / Adempiere, servidores, sistemas operacionais, banco de dados, etc.
odilberto
Mensagens: 27
Registrado em: Ter Jan 12, 2010 6:23 pm

postgres ??? qual versao??

Mensagempor odilberto » Sex Jan 29, 2010 4:08 pm

galera... to apanhando a beça pra instalar o adlbr... baixei o jdk1.0.6u18... instalado
so queria saber de vcs qual a versao do postgre mais estavel pra instalar o adlbr
pq todas as q estou tentando principalmente a mais nova 8.4... nao funciona
da erro um atras do outro
e e sempre de conexao

aguardo retorno

obrigado

ralexsander
Mensagens: 579
Registrado em: Ter Nov 21, 2006 7:43 am
Localização: São Paulo
Contato:

Re: postgres ??? qual versao??

Mensagempor ralexsander » Sex Jan 29, 2010 4:15 pm

Odilberto,

Tente a versão mais recente do PG. Version 8.4.2-1.

Não recomendo o JDK 6u18, recomendo o JDK 6u11 (http://java.sun.com/products/archive/j2 ... index.html).

Se o erro é de conexão dê uma olhada no seu postgresql.conf e pg_hba.conf.

Tente conectar como LOCALHOST também para saber se o erro é nos arquivos citados.

Att.
Ricardo Alexsander Santana
http://www.kenos.com.br

odilberto
Mensagens: 27
Registrado em: Ter Jan 12, 2010 6:23 pm

Re: postgres ??? qual versao??

Mensagempor odilberto » Sex Jan 29, 2010 4:49 pm

obrigado pelo retorno mas a versao do pg q vc sugeriu nao tem a opcao de instalacao do PL/Java... qdo checo o postgres.conf no final do arquivo nao aparece a linha com o caminho p o pl/java... e ai?

ralexsander
Mensagens: 579
Registrado em: Ter Nov 21, 2006 7:43 am
Localização: São Paulo
Contato:

Re: postgres ??? qual versao??

Mensagempor ralexsander » Sex Jan 29, 2010 5:05 pm

Na pasta que instalou o PG dê uma olhada se existe na pasta lib o arquivo pljava.jar.

Se sim, adicione o seguinte no seu arquivo postgresql.conf

custom_variable_classes = 'pljava'
pljava.classpath = '<<caminho do postgres>>/lib/pljava.jar'

No seu path adicione o caminho do jdk/bin, jre/lib/i386, /jre/lib/i386/client, /jre/lib/i386/native_threads.

Ai entre na pasta share/pljava do seu postgres, e execute o psql -f install.sql

Abraço.
Ricardo Alexsander Santana
http://www.kenos.com.br


Voltar para “Infraestrutura”

Quem está online

Usuários neste fórum: Nenhum usuário registrado e 1 visitante