ZK Webui no AdempiereLBR não funciona.

Espaço para os tópicos específicos das adaptações "Brasil" necessárias para utilização do Compiere /Adempiere por aqui.
Renato Corrêa
Mensagens: 3
Registrado em: Seg Ago 12, 2013 4:38 pm

ZK Webui no AdempiereLBR não funciona.

Mensagempor Renato Corrêa » Qua Fev 19, 2014 4:54 pm

Olá pessoal.

Estou precisando de ajuda. Eu não consigo rodar as modificações que estou fazendo no ZK webui no AdempiereLBR.

Já adicione no Classpath todos os .jars do tomcat , dos projeto Adempiere Global e AdempiereLBR. Mas todas as modificações que faço no arquivo index.zul (que está dento do AdempiereLBR) não funcionam. Funciona somente o index.zul (que está dento do Adempiere Global).

Deve haver alguma configuração que não fiz. Será que alguém pode me ajudar?

Se não ficou muito claro a minha duvida, eu posso explicar de outra forma.

Grato pela atenção de vocês.

ralexsander
Mensagens: 579
Registrado em: Ter Nov 21, 2006 7:43 am
Localização: São Paulo
Contato:

Re: ZK Webui no AdempiereLBR não funciona.

Mensagempor ralexsander » Qua Fev 19, 2014 6:00 pm

Olá Renato,

Por favor coloque mais detalhes... Qual versão do Adempiere e qual branch do LBR você está usando?

Não funciona no seu ambiente de desenvolvimento ou direto no servidor?

Abs!
Ricardo Alexsander Santana
http://www.kenos.com.br

Renato Corrêa
Mensagens: 3
Registrado em: Seg Ago 12, 2013 4:38 pm

Re: ZK Webui no AdempiereLBR não funciona.

Mensagempor Renato Corrêa » Qui Fev 20, 2014 10:25 am

ralexsander escreveu:Olá Renato,

Por favor coloque mais detalhes... Qual versão do Adempiere e qual branch do LBR você está usando?

Não funciona no seu ambiente de desenvolvimento ou direto no servidor?

Abs!


Obrigado Ricardo pelo retorno.

No meu eclipse eu tenho os dois projetos. O AdempiereLBR da branch 'kenos' e o AdempiereGlobal 360. Já configurei o classpath.

Quando crio o custom e rodo no servidor ou compilo os dois projetos, as modificações que eu fiz no AdempiereLBR funcionam normalmente.

Mas a versão web não funciona no meu ambiente de desenvolvimento e nem direto no servidor. Toda as modificações que eu faço no lbr ( nos arquivos .zul que estão dentro da pasta zkwebui) não aparecem.

Aparece somente a versão do AdempiereGlobal. Onde não fiz nenhuma modificação.

Por exemplo eu tentei modificar o arquivo index.zul no AdempiereLBR, mas ele não rodou. Ficou aparecendo somente a index.zul do AdempiereGlobal.

Como faço para modificar os arquivos .zul do AdempiereBLR e colocar essas modificações em ação?

Tks

ralexsander
Mensagens: 579
Registrado em: Ter Nov 21, 2006 7:43 am
Localização: São Paulo
Contato:

Re: ZK Webui no AdempiereLBR não funciona.

Mensagempor ralexsander » Qui Fev 20, 2014 2:45 pm

Pode ser problema com a ordem dos projetos no classpath...

Assumindo que você configurou o Adempiere para rodar no Tomcat (http://www.adempiere.com/Creating_WebUI ... se_Webtool) dê uma olhada na configuração a seguir:

Menu Run > Run Configurations...

No grupo Apache Tomcat, selecione o seu projeto e clique na aba Classpath. No grupo User Entries o projeto AdempiereLBR deve estar por cima do projeto Adempiere (eu coloco em primeiro da lista).

Abs!
Ricardo Alexsander Santana
http://www.kenos.com.br

Renato Corrêa
Mensagens: 3
Registrado em: Seg Ago 12, 2013 4:38 pm

Re: ZK Webui no AdempiereLBR não funciona.

Mensagempor Renato Corrêa » Qui Fev 20, 2014 6:11 pm

ralexsander escreveu:Pode ser problema com a ordem dos projetos no classpath...

Assumindo que você configurou o Adempiere para rodar no Tomcat (http://www.adempiere.com/Creating_WebUI ... se_Webtool) dê uma olhada na configuração a seguir:

Menu Run > Run Configurations...

No grupo Apache Tomcat, selecione o seu projeto e clique na aba Classpath. No grupo User Entries o projeto AdempiereLBR deve estar por cima do projeto Adempiere (eu coloco em primeiro da lista).

Abs!



Oi Ricardo eu já tinha conferido a ordem dos projetos no classpath e estão ok.

Não quero tomar o teu tempo.. mas tu acha que poderia ser alguma outra coisa? É somete os arquivos .zul que não estão funcionado.

Agradeço a tua atenção.


Voltar para “Localização Brasil”

Quem está online

Usuários neste fórum: Nenhum usuário registrado e 2 visitantes