Agendador

Espaço para tópicos sobre funcionalidades padrão do Compiere / Adempiere.
marcped10
Mensagens: 10
Registrado em: Qui Ago 04, 2011 3:03 pm

Agendador

Mensagempor marcped10 » Qui Ago 04, 2011 3:31 pm

Boa tarde pessoal,
Estou com o seguinte problema, quando crio um menu e rodo meu processo diretamente ele funciona numa boa. Mas quando cadastro ele no Agendador e rodo no servidor de aplicação da o erro "ClassNotFound', não entendo pq não esta encontrando minha classe. Alguma sugestão ???

[]s

ralexsander
Mensagens: 579
Registrado em: Ter Nov 21, 2006 7:43 am
Localização: São Paulo
Contato:

Re: Agendador

Mensagempor ralexsander » Qui Ago 04, 2011 3:42 pm

Olá,

O problema é que com o agendador o processo roda no Servidor de Aplicação e não localmente. O seu servidor de aplicação não deve estar atualizado com o código do seu eclipse.

Se você fez as modificações em um projeto separado, gere um JAR com a classe modificado, renomeie para customization.jar, coloque na pasta LIB do seu servidor e rode o processo de RUN_SILENTSETUP.SH/BAT se você alterou diretamente no adempiere rode o RUN_BUILD.SH/BAT na pasta UTILS_DEV e re-instale seu servidor com os novos arquivos que são gerados na pasta INSTALL/BUILD.

Abs
Ricardo Alexsander Santana
http://www.kenos.com.br

marcped10
Mensagens: 10
Registrado em: Qui Ago 04, 2011 3:03 pm

Re: Agendador

Mensagempor marcped10 » Qui Ago 04, 2011 3:52 pm

Obrigado, vou tentar fazer aqui.
[]s

marcped10
Mensagens: 10
Registrado em: Qui Ago 04, 2011 3:03 pm

Re: Agendador

Mensagempor marcped10 » Qui Ago 04, 2011 4:09 pm

Amigo olhei aqui minha customization.jar do servidor de aplicação e notei que minhas classe esta lah sim, entao acho q o vc falou não vai adiantar muito neh =x
de qualquer forma farei tudo novamente.

[]s

marcped10
Mensagens: 10
Registrado em: Qui Ago 04, 2011 3:03 pm

Re: Agendador

Mensagempor marcped10 » Qui Ago 04, 2011 4:29 pm

Não sei se ajuda, mas estou usando o 3.60.

[]s

ralexsander
Mensagens: 579
Registrado em: Ter Nov 21, 2006 7:43 am
Localização: São Paulo
Contato:

Re: Agendador

Mensagempor ralexsander » Qui Ago 04, 2011 4:34 pm

Se o erro é ClassNotFound não vejo como ser outro problema.

Lembre-se que mesmo o customization.jar contendo sua classe no servidor, ainda assim é necessário rodar o processo RUN_Setup ou RUN_silentsetup.

Att.
Ricardo Alexsander Santana
http://www.kenos.com.br

marcped10
Mensagens: 10
Registrado em: Qui Ago 04, 2011 3:03 pm

Re: Agendador

Mensagempor marcped10 » Ter Out 04, 2011 11:21 am

Alem de usar os RUN_Setup ou RUN_silentsetup, usei o RUN_UPDATE ae passou a dar certo ^^
Obrigado ^^


Voltar para “Funcional”

Quem está online

Usuários neste fórum: Nenhum usuário registrado e 1 visitante